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Writer Main Window And InterfaceWriter Main Window And Interface    



The main Writer workspace shown in the image below contains the  
following parts:

1. Title bar. Displays current filename and application

2. Menu bar. The main application menu with access to all the command and features

3. Standard toolbar. Quick access to basic commands

4. Formatting toolbar. Quick access to basic formatting commands

5. Sidebar. Access to properties, styles, gallery and navigator

6. Status bar. General information about the current document and view control

7. Default File Name: Untitled 1

8. Default Zooming Range :  100%

9. Minimum Zooming Range : 20%

10.Maximum Zooming Range : 600%

11.Default Font Size : 12

12.Minimum Font Size : 6

13.Maximum Font Size : 96

14.Minimum Font Size (Manually): 2

15.Maximum Font Size (Manually) : 999.9

16.Default Font Name : Liberation Serif



CreatingCreating    

When you open Writer by default creates a new empty document. You can also create a new Writer document using the   
icon from the Standard Toolbar.

OpenOpen    

To open a document stored on your computer or other remote location use the   icon and specify the file location in the Open
File Dialogue window.

SavingSaving    

To save a document use the   icon. The first time you save a document the Save as Dialogue appears and prompts you to give
a name, path and file format for the document (the default format is odt). From now on every time you press the save button all 
your changes will be automatically saved.

While working on a document you should save your changes frequently to avoid loss of your work in case of power loss or 
other system failure.

Save asSave as    
In the Save As Dialogue window specify the new filename and path. The copy of your document will now become the active file
in Writer.



Exporting to PDFExporting to PDF    
When sharing documents with others it's a good practice to use the PDF format. To export a document to PDF click on the 
button in the Standard Toolbar. On the Export Dialogue window press the Save button to save the file as pdf.

Selecting and moving textSelecting and moving text    
A large part of text editing involves selecting, coping and moving text inside a document and undoing our action in case of 
mistakes. The proper knowledge of these techniques can save us a lot of time while editing documents. Furthermore these 
techniques are universal and can be applied to many applications. 

Selection TechniquesSelection Techniques    
While editing a document we frequently need to select parts of our text in order to apply formatting or just copy or move them. 
The following table lists the selection techniques, their action and an example image. When selecting text Writer highlights the 
text with a background color.

Technique Action Image

single word Double click

sentence Triple click

paragraph
Click four 
times in a row

 



Technique Action Image

multiple 
selections

Hold down 
CTRL button 
while clickng

 

continuous 
selection

Click at the 
beginning and 
then hold 
SHIFT and 
click to the 
end

 All text  CTRL + A

 



Cut Copy and PasteCut Copy and Paste    
To cut, copy and paste you can use the corresponding buttons from the Standard Toolbar.

However you are advised to learn using the keyboard shortcuts for cut, copy and paste, because these commands are very often 
used in word processing. These keyboard shortcuts are universal to almost all applications and platforms.

Keyboard shortcutsKeyboard shortcuts    

•Cut: CTRL + X
•Copy: CTRL + C
•Paste: CTRL + V
•Paste Unformatted: CTRL + SHIFT + V

Copy and paste from other sourcesCopy and paste from other sources    
When coping text from other sources (for example other documents, websites) Writer tries to copy the formatting of the source 
as well. This creates many problems (known as formatting hell) and is a very common and sad mistake even to experienced 
users.

In contrast with normal pasting unformatted pasting does not keep the formating of the source. Therefore you should normally
use unformatted pasting when copying from other sources outside your original document.

To paste Unformatted:To paste Unformatted:    

•Use the CTRL + SHIFT + V key
combination or

•Right click and select the Paste Special menu command



Moving and copyingMoving and copying    
To copy or move text inside your document:

•Use mouse drag and drop technique

•Use cut, copy and paste commands

Drag and dropDrag and drop    
Select the text to be moved or copied and drag with your mouse to the new position indicated by the cursor. This action by 
default moves text, to copy hold down the CTRL key while dragging

Cut, copy and pasteCut, copy and paste    
•To move a selection: Cut, click on the new location and Paste.

•To copy a selection: Copy, click on the new location and then Paste.

Undo and RedoUndo and Redo    
While we edit a document every change we make is being registered automatically. This is useful because it allows us 
to undo an action and go back to the previous state. For example if you accidentally delete a paragraph we can simply undo your
action. Now if you decide that you want to delete it after all you can redo you last action.

So basically undo and redo allows us to go back and forth in our document editing history.



Find and ReplaceFind and Replace    
When you're working with large documents, it can be hard and time consuming to locate a specific word or phrase. With 
Writer's Find and Replace feature you can quickly search for text inside a document and to quickly replace it with a replacement
text. 
Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find & Replace Dialogue 
which has the replace feature.

Find toolbarFind toolbar    

Open the Find toolbarOpen the Find toolbar    

You can display the Find toolbar by by pressing Ctrl+F key combination or choosing Edit > Find from the Menu bar.

Using the Find toolUsing the Find tool    

To look for a word or phrase, click in the box and type your text, then press Enter to find the next occurrence of that term from 
the current cursor position.

Click the   Find Next or Find Previous buttons as needed.

Click the Find All button to select all instances of the search term within the document.

Select Match Case to find only the instances that exactly match the search term.



Find & ReplaceFind & Replace    

Opening the Find & Replace toolOpening the Find & Replace tool    

To display the Find & Replace Dialogue, click on the   icon, or use the keyboard shortcut Ctrl+H. When the Dialogue is 
open, optionally click Other Options to expand it.

Using the Find & Replace Dialogue:Using the Find & Replace Dialogue:    

1.Type the text you want to find in the Find box.

2.To replace the text with another text, type the
new text in the Replace box.

3.You can select various options such as
matching the case, matching whole words only,
or doing a search for similar words.

4.When you have set up your search, click Find
Next. To replace the found text, click Replace.

TipTip    
If you click Find All, LibreOffice selects all instances
of the search text in the document. Similarly, if you
click Replace All, LibreOffice replaces all matches,
without stopping for you to accept each instance.



Character formattingCharacter formatting    
Character formating refers to the formating you can apply at the character level, meaning that you can even format an individual
character besides a word or any part of a text. 

Basic character formattingBasic character formatting    

The following table lists all the formatting commands and their result on the applied text



Apply character formattingApply character formatting    

You can apply character formating using the

•Formatting Toolbar

•Sidebar or

•Character Formatting Dialogue window

In any case before formatting you must select the text and then apply the formatting command. If the text you want to select is a
single word then you can just click inside the word instead of selecting all the word.

The Formatting ToolbarThe Formatting Toolbar    
The quickest way to apply character formatting is the Formatting Toolbar.

To apply character formatting

1.First select your text and

2.Click one of the available formatting buttons.

When you click inside a formatted text the toolbar's icon is highlighted indicating the formatting.



You can also combine formatting styles, for example you can apply bold, italic and strike-through to a text.

Sidebar Character section

You can also use the Sidebar's Character section in properties tab
to format characters. The panel contains some extra buttons not
found in Formatting toolbar.



Character Formatting Dialogue windowCharacter Formatting Dialogue window    

To open the Character formatting window click the   icon in the sidebar or use the context menu item. In this window you 
have all the character formatting options available such as font effects and borders

Clear direct formattingClear direct formatting    
Direct formatting refers to the formatting you apply manually in a text. Later in this course you will learn how to apply 
formating using styles which is the recommended method.

When you need to clear all formatting and start over, select the text and click the   icon on the Formatting toolbar. This is 
will set all formatting to the default values.

Clone FormattingClone Formatting    
You can quickly copy or clone a set of formatting commands that has been applied to a text to another using the Clone 

Formatting   tool.

1.Click anywhere inside the source text

2.Click on the Clone Formatting   button, or double click to make multiple clones

3.Click or drag with the clone brush to the destination text to clone the source formatting



Tips about fontsTips about fonts    
•A font style can applied to a document only if installed in your system. LibreOffice lists all available fonts installed in 
your system. However Writer can display fonts not installed in your system when these are embedded inside a document.

•Some fonts are only available for specific languages, therefore setting a font to a text in a non supported language will 
not have any effect.

•Use simple and readable fonts on your documents.

•Avoid the use of multiple fonts inside a document.

Paragraph formattingParagraph formatting    
Paragraph formatting refers to formatting that is paragraph-specific. That is, rather than affecting individual words or sentences, 
it affects the entire paragraph. Common paragraph formatting that you can apply includes alignment, indents and spacing. You 
can also create bulleted or numbered lists, and add borders or shading.

What is a paragraph?What is a paragraph?    

In Writer and other word processors in general, a paragraph is a
block of text that ends with a new line character. Every time you
type the Enter key a new line character is inserted, creating this way a paragraph. To display the new line and other hidden 

characters click on the   button in Standard Toolbar.

To create dummy text like in the videos in this course:
1. type DT and then
2. press the F3 function key.



Applying paragraph formattingApplying paragraph formatting

To apply formatting to one ore more paragraphs:

1.First select the paragraph. In case of a single paragraph just click anywhere inside a paragraph. For multiple paragraphs 
you must make a multiple or continuous selection of all text in the paragraphs.

2.Then use the buttons on the Formatting toolbar, Sidebar Paragraph section or the Paragraph 
Formatting Dialogue window.

Paragraph alignmentParagraph alignment    

A paragraph can be aligned horizontally
left, center, right or justified left and right.

The following image shows the four types
of paragraph alignment.

To align a paragraph use the following
buttons found in Formatting Toolbar.



Indents and spacingIndents and spacing    
Paragraph indent is the spacing between a paragraph and the left or right margins of the page. Paragraph spacing refers to the 
white space between paragraphs
or other objects such as graphics
or tables. Line spacing is the
space between lines of a
paragraph.

The following image shows the
indent and spacing properties of a
paragraph. alignment



Set indents and spacingSet indents and spacing    

You can quickly indent a paragraph or change spacing with the buttons in Formatting Toolbar:

Using the slidersUsing the sliders    
A more practical way to change indents it to use the three sliders (triangles) in the horizontal ruler to indent a paragraph.



Using the SidebarUsing the Sidebar    

You can use the Sidebar Paragraph section in Properties panel to apply all the above commands for paragraph formatting. The
sidebar includes some extra command such as Background Color and the ability to type numerical values for setting indents and
spacing.



The Paragraph formatting Dialogue windowThe Paragraph formatting Dialogue window    
Using this window you have access to all Paragraph formatting commands. This includes Borders, Area and Drop Caps.

To open this window click on the   icon in Sidebar or use the Paragraph... context menu item.



Bulleted and Numbered ListsBulleted and Numbered Lists    
Numbered and bulleted lists can be used in a document to keep related items together, show the level of importance and outline 
text. Text is more readable in  list format.

Numbered lists work best when the order or sequence is important. Bulleted lists work best when the order doesn’t matter, but 
items in the list are related.

Creating listsCreating lists    

To create a list in Writer all items must be paragraphs separated with a new line character. To create a list:

1.Select all list items

2.Click the Bulleted   or Numbered   List button on the Formatting Toolbar.

Bulleted list.  Numbered list.

To remove bullets or numbering select the list items and click again on the Bullets or Numbering button to disable the list 
formatting.



Format bullets or numbersFormat bullets or numbers    

To change format of the bullets or numbers in a list:

1.Select first all list items and click the arrow on the Bulleted or Numbered list icon  .

2.In the drop-down panel choose the new format for bullets or numbers:

Bulleted list format  Numbered list format



Bullets and Numbering Dialogue windowBullets and Numbering Dialogue window    

For more option click More Bullets... or More Numbering... option to open the Bullets and Numbering Dialogue window. In 
the Image tab you can set an icon for the bullets or add an image from your computer.



Nested listsNested lists    

List items can be promoted one or more levels creating this way hierarchical or nested lists. Use the Promote and 

Demote   buttons to increase or decrease the level of a list item or items. The Promote and Demote with 
subpoints command changes the level of the selected item including all nested items (subpoints).

Moving list itemsMoving list items    

You can easily move list items using the Up and Down   arrows on the Toolbar. The
Move with subpoints command moves a list item including all nested items (subpoints).

Inserting unnumbered or unbulleted textInserting unnumbered or unbulleted text    

Sometimes we need to insert text in a list without the bullets or numbers. Click first on a list item

and then click on the   icon to insert a line with no list formatting. An alternative way to achieve
this is to insert a Line Break character using the CTRL + ENTER key combination.



Restarting list numberingRestarting list numbering
Sometimes the numbering continues to the next list like the image below. If this is not the desired behavior you can restart the 

numbering using the   icon on the Bullets and Numbering toolbar.



Inserting imagesInserting images    
When you create a text document using LibreOffice Writer, you may want to include some illustrations (images or graphics). 
Images in Writer are of three basic types:

•Image files, such as photos, drawings, and scanned images

•Diagrams created using LibreOffice’s drawing tools

•Charts created using LibreOffice’s Chart facility

Inserting an image into a document.Inserting an image into a document.    

1.Insert Image Dialogue1.Insert Image Dialogue    

To insert an image stored on your computer click the   icon or use the Insert > Image menu command. On the Insert Image 
Dialogue, navigate to the file to be inserted, and select it. To preview images tick the Preview option.

2.Drag and Drop2.Drag and Drop    

1.Select am image from the file browser window

2.Drag the image into the Writer document and

3.Drop it where you want it to appear.



3. From the clipboard3. From the clipboard    

You can simply copy (CTRL + C) an image from the file explorer or any application that can open images and then simply paste
(CTRL + V) the image to a writer document.

4. Using the Gallery4. Using the Gallery    

The Gallery is a collection of graphics and is available in all components of LibreOffice. It comes with many images, but you 
can still add your own pictures.

1.To open the Gallery, click on the Gallery icon   located in the Sidebar

2.Navigate through the Gallery to find the desired picture.

3.To insert the picture, click and drag it from the Gallery into the Writer document



Changing the measurement UnitsChanging the measurement Units    
Because you are going to work with graphics you probably need to change the measurement units of Writer application 
to centimeters.

1.From the Writer menu choose Tools > Options and

2.Browse the Writer General category

3.Change the Measurement Units to centimeters



Positioning imagesPositioning images    
Positioning of an image is controlled by four settings:

1.Text wrapping

2.Alignment

3.Anchoring

4.Arrangement

Text wrappingText wrapping    

Text wrapping refers to the relation of images to the surrounding text, which may wrap around the graphic on one or both sides, 
be overprinted behind or in front of the graphic, or treat the graphic as a separate paragraph or character.

Wraping Description Image

No Wrap With this option the text is placed above and below the image 
but not to either side of it. This is the wrapping type used for 
most of the figures in this guide.



Wraping Description Image

Page Wrap The text flows around the image. Moving the image around the
page causes the text to be rearranged to fill the space to the left 
and right of it.

Optimal Page 
Wrap

Optimal Page Wrap prevents text from being placed to the side 
of the image if the spacing between the image and the margin is
less than 2 cm.

 Wrap Through
 Superimposes the image on the text. That is, the image is in 
front of the text. This option must be used in conjunction with 
the image-transparency setting in order to make the text under 
the picture visible.

 



AlignmentAlignment    

Alignment refers to the vertical or horizontal placement of an image in relation to the chosen anchor point. To align an image 
use the alignment buttons on the image toolbar.

AnchoringAnchoring    

Anchoring refers to the reference point for the images. An image always has an anchor point with the   icon. To set the 
anchoring type click on the anchor button in the image toolbar an choose one of the options. Note that you should use To 
Paragraph setting most of the time to avoid confusion.



Anchoring Description Image

To Page
The graphic keeps the same position in relation to the page 
margins. It does not move as you add or delete text or other 
images.

To Paragraph
The graphic is associated with a paragraph and moves with the 
paragraph. This method is used most often.

As Character

The graphic is placed in the document like any other character 
and, therefore, affects the height of the text line. The graphic 
moves with the paragraph as you add or delete text before the 
paragraph. This method is useful for adding a small (inline) 
icon in a sentence.



ArrangementArrangement    

Arrangement controls how images are stacked upon each other or relative to the text. You control the arrangement with these 
buttons in the Frame Toolbar.

The buttons are

•Bring graphic to the front (all the levels)

•Forward graphic one level up

•Back graphic on level down

•Send graphic to back (all levels)



Modify imagesModify images    
When you insert a new image, you may need to modify it to suit the document. Writer provides many tools for working with 
images like resizing, cropping and color changing.  

The Image ToolbarThe Image Toolbar    

When you insert an image or select one already present in the document, the Image toolbar appears. You can do most of the 
image editing tasks using this toolbar

ResizingResizing    

To resize an image simply drag with the mouse one of the green sizing handles. In this way the image is 
resized proportionally and keeps the original ratio between width and height.

To resize the width or height only hold down the shift button while dragging the green point



CroppingCropping    

When you are only interested in a section of the image
for the purpose of your document, you may wish to crop
(cut off) parts of it. To crop an image first click on the

crop icon   and then drag one of the red cropping
handles points.



Flip and RotationFlip and Rotation    

You can flip and rotate an image using these buttons 

TransparencyTransparency    

Modify the percentage value in the Transparency box on the Image
toolbar to make the image more transparent. This is particularly useful
when creating a watermark or when wrapping the image in the
background. 

ColorsColors    

Use the Colors toolbar to modify the individual RGB color
values of the image (red, green, blue) as well as
the brightness, contrast, and gamma of the image. If the
result is not satisfactory, you can press Control+Z to
restore the default values. To open the colors toolbar click

on the   icon



BordersBorders    

You can add borders to an image the same way as in paragraphs using the buttons from the Frame 

toolbar 

More image editing commandsMore image editing commands    

For more options in modifying images you can double click on an image and display the Image properties window or use the 
sidebar.



Creating TablesCreating Tables    
Tables are a useful way to organize and present large amounts of information, for example:

• Technical, financial, or statistical reports.

• Product catalogs showing prices and characteristics.

• Lists of names with address and other information.

Tables can also be used to create more complex layouts in a page and position and align text and graphics.

Before you insert a table into a document, it helps to have an estimate of the number of rows and columns required.  A row is a 
horizontal series of cells, while a column is a vertical series.



Inserting a new tableInserting a new table    

Quick insert

1.To insert a new table, position the cursor where you want the table to appear

2.Click the Insert Table   icon on the Standard toolbar

3.Select the number of rows and columns you require

Using the Insert Table DialogueUsing the Insert Table Dialogue    

If you click on the More Options button you can specify more properties for the new table

Heading. Select this option if the first row of the table contains
the named of the columns and not actual data. This makes the
first row to be a formatted as a heading

Repeat Heading Rows on new pages. Makes the heading row
to appear in every page if the table is large enough.

Don’t split table over pages. Prevents the table from spanning
more than one page.

Border. Surrounds each cell of the table with a border.



Create a table from formatted textCreate a table from formatted text    

You can create a table from plain text by using the Text to Table tool. The text to be converted must contain characters to 
indicate column separators. Paragraph marks, indicate the end of a table row.

For the example the text below separates columns with commas (,) and rows with
paragraphs.

Name, City, Age
George, Syros, 33
Nick, Athens, 22
Elena, Paris, 19
Select the text and choose the Table > Covert > Text to Table menu command.

When the Convert Text to Table Dialogue appears we set commas as separator

And the resulting table:



Table cell formattingTable cell formatting    
Once the table layout is satisfactory, you can move on to formatting the text in the individual cells. You can format each cell 
independently of other cells, or you can simultaneously format a group of cells by selecting them before applying the desired 
formatting. 

AlignmentAlignment    

Table cells can be aligned both vertically and horizontally. To align horizontally use the horizontal alignment buttons from the 
Formating toolbar.

To align vertically use the vertical alignment buttons from the Table toolbar.

Background colorBackground color    

To change the background color of an individual or group of cells, select the cells and click on the   button on the Table 
toolbar.



BordersBorders    

You can apply borders to any cell or group of cells using the table borders buttons in Table toolbar. Set the border layout, line 
type and color.

To change more border options open the Borders tab in Table formating window

Number formatNumber format    

Numerical data can be formatted into various formats. For example, cells can be set to display in a particular currency, 
to percentage, to 2 decimal places. To quickly format numbers in a table use the number format buttons. For more options open
the Number Format Dialogue window.

Some examples of number formating are shown in the table below:



Protect cellsProtect cells    

Protecting a cell prevents the user from accidentally changing the data. This can be useful when you want the users to edit only 
part of the table.

To protect a cell select it and the click on the   button.

To cancel the protection click on the   button.

SortingSorting    

Writer allows data in a table to be sorted. Up to three levels of sorting can be specified. For example, sort first by age 
numerically, then alphabetically by name within each age.

To sort data in a table:

1.Select the table (or part of the table) to be sorted.

2.Select the Sort icon   from the Table toolbar.

In the Sort Dialogue:

1.Select the column number (key) to be sorted.

2.Select up to three keys to sort on, in the correct order.

3.For each key, select whether the sort is Numeric or
Alphanumeric and whether it is Ascending or Descending.



Page size, margins and orientationPage size, margins and orientation    
Page formatting in word processors refers to page printing layout properties (size, margins and orientation) and page 
elements such as headers, footers, borders and background.

Normally page formatting affects all pages inside a document. Later in this course you will learn how to format individual pages
using Page Styles.

Page propertiesPage properties    

To quickly edit basic page properties such as paper size, margins and orientation use the Sidebar's Page section in properties tab.

For more options choose the menu item Format > Page to open the Page formating window.

OrientationOrientation    

Writer offers two page orientation options: landscape and portrait. Landscape
means the page is oriented horizontally, while portrait means the page is
oriented vertically.  See how orientation can affect the appearance of a page in
the image below.



Setting the orientationSetting the orientation    

To change the orientation click on the   button on the Page panel of the Properties deck in sidebar.

Page MarginsPage Margins    

Page margins are the white space around the top, bottom, left, and right of your document. Margins serve two main purposes:

All printers require a space between the printing area and the edge of the paper because printing on the edges is hard if not 
impossible for most printers

The use of white space around the content of a page makes our document more easy to read and visually appealing.

Setting page marginsSetting page margins

Using the sidebar
In general you should avoid changing margins for most of your
documents. However some types of documents like posters, brochures etc
may require to change the margins. To set the margins of your document

click the   button on the Page panel of the Properties deck in sidebar.

Choose Narrow, Normal, Wide or set custom values.



Using the rulersUsing the rulers    

The shaded sections of the rulers are the margins. Put the mouse cursor over the line
between the gray and white sections. The pointer turns into a double-headed arrow.

Hold down the left mouse button and drag the mouse to move the margin.

You need to be careful to move the margin marker, not the arrows arrows on the ruler, these
are used for indenting paragraphs.

Background and BordersBackground and Borders    
You can apply borders and backgrounds to pages in Writer as with paragraphs and other elements. Page background and 
borders fill the area within the margins, including the header or footer
(if any). 

BordersBorders    

To edit page borders click on the   icon on the Page panel of the
Properties deck in sidebar to open the Page Style Dialogue and select
the Borders Tab.

In this window you can set the border settings
•line arrangement
•line style, width and color,
•shadow
•spacing to contents

To set more complex line arrangements click on the User-defined box



BackgroundBackground

Background AreaBackground Area    

To set the page background first click on the   icon on the Page panel of the Properties deck in sidebar to open the Page Style 
Dialogue and select the Area Tab. Here you can choose one of the background options.

With the bitmap option you can set a graphic as a page
background.

Background TransparencyBackground Transparency    

If the background makes the text difficult to read you can set
a transparency to the background. Click on the Transparency
tab and increase the setting to a desired value.



Headers and FootersHeaders and Footers    
Headers are portions of a document that always appear at the top of a page, footers appear at the bottom of a page. Typically 
headers and footers display general information such as document title, chapter name, page number, author name etc.

Headers and footers can help keep large documents organized and make them easier to navigate. Normally text entered in the 
header or footer will appear on each page of the document but you can create separate header and footer for a section of a 
document (for example the first page).



Creating headers and footersCreating headers and footers    

Directly into the documentDirectly into the document    

The simplest method to insert a header is

1.Click above the top of the text area and when when the Header marker appears

2.Click on the + icon.

Now you can type and format the header text as any other text.

To insert a footer follow the same steps by clicking on bottom of the text area to display the Footer marker.

Using the Page Style DialogueUsing the Page Style Dialogue    

With this method you can create headers and footer
with some advanced options. Open the Page Style
Dialogue window and enable the header and/or
footer.



Format headers and footerFormat headers and footer    

Clicking on a header marker opens a context menu with the following commands

•Format Header. Opens the Header tab in Page style window

•Border and Background. Set borders and background for the header area

•Delete Header. Remove the header

The same apply for the footer area.

Numbering PagesNumbering Pages    

In formal and long documents you normally need to display the current page number in header or footer. Instead of manually 
typing each page number you should use fields to let LibreOffice automatically display the numbers. 



Simple Page NumberingSimple Page Numbering    

First create a header of footer to place the page numbering. To insert a page number field, click on the   icon in the Standard 
toolbar and choose Page Number field.

The page number appears with a gray background. The gray background denotes a field; although it is visible on screen, the 
gray background it is not printed. The page number field always displays the page number for the page where it is placed.

Now the correct page number appears on every page.



Line and Page BreaksLine and Page Breaks    
One of the common pitfalls in text editing is the use of empty lines to force a new line or page. Line and page breaks are handy 
little features of every word processing application that sadly most users ignore their existence. Learn how to use them properly 
and you will stand out from the crowd of mediocre users. 

Page BreakPage Break    

A Page Break is a special character inserted by a Word
processor like Writer that marks the end of the current page.
In cases where you need to have text begin on a new page,
such as the beginning of a new chapter, insert a page break
at the point where you want the new page to begin.

Don’t press the Enter key repeatedly until a new page begins. If you later add text 
before the empty lines, then you will have to manually correct all the pages. 
Imagine this happening to a 100 page document!



Insert and delete a Manual Page BreakInsert and delete a Manual Page Break    

To Insert a Manual Page Break

1.Click in your document where you want the new page to begin.

2.Press Ctrl+Enter.

To Delete a Manual Page Break

1.Click in front of the first character on the page that follows the manual page break.

2.Press Backspace.

Line BreakLine Break    

A Line Break is a special character inserted by a Word processor like Writer that creates a new line without creating a new 
paragraph.

One use of line break is
when we want to create new
lines without inheriting
paragraph properties such as
spacing, bullets or
numbering.



Insert and delete a Line BreakInsert and delete a Line Break    

To insert Line Break press Shift + Enter

To delete use Backspace

Display line and page breaksDisplay line and page breaks    

To Hide or View line and page breaks click on the   icon

Column LayoutColumn Layout    

In LibreOffice Writer a page can be formated with multiple columns. The default page layout is the one column layout which is
the layout the majority of the documents use. However, some types of documents such as newspapers, leaflets, scientific papers 
and reports use two or more columns. 

Page column layoutPage column layout    

When formating a page with a two column layout for example,
the page is divided in two columns. Text flows from the left to
the right column.

To format a page with column layout, click on columns   
icon in the page properties pane of the Sidebar

Choose one of the predefined column layouts of click on More
Options to open the columns tab in Page Style window.



Format a section of a page with columns.Format a section of a page with columns.    

First select the text of the section you want to create and format with columns

From the main menu click on Format > Columns menu command.



Make sure the Apply to Selection is selected and choose
the number of columns. It's good also to put
some spacing between the columns. You can also set
a separator line.



Track, Accept and Reject ChangesTrack, Accept and Reject Changes    
LibreOffice Writer provides below options for Track Changes.

It has options to record the changes, show/hide, manage, browse the changes in the document. It also provides a way to
accept or reject the changes as part of the review process in a document.

Track Changes ToolbarTrack Changes Toolbar

You can also find these options in a toolbar via View -> Track Changes.

https://libreofficehelp.com/wp-content/uploads/2020/07/Track-Changes-Options.png
https://libreofficehelp.com/wp-content/uploads/2020/07/Workspace-1_048.png


Start the ChangesStart the Changes    

To start the track changes in any document, from menu select Edit -> Track Changes -> Record Or press Shift + 
Ctrl + C. Once you do that your document is in review mode.

Any change you do now would be highlighted based on the changes you are making.

For example, if you delete any portion of the document, it would be highlighted like this. Note that the author’s name, 
date, and time of the change also recorded.

Changes RecordedChanges Recorded

When you save the document and
distribute it via email or any means, all the
changes would be highlighted and send
over. That means, whoever opens up the
document, can see all the changes
including who made them.

https://libreofficehelp.com/wp-content/uploads/2020/07/Changes-Recorded.jpg


Accept and RejectAccept and Reject    

The changes can be reveiewed and accepted/rejected from the context menu. Right-click on the changed portion and 
click Accept Changes or Reject Changes. If you like you can add comments as well.

Accept and Reject Changes in MenuAccept and Reject Changes in Menu

https://libreofficehelp.com/wp-content/uploads/2020/07/Accept-and-Reject-Changes-in-Menu.png


Comment-is-changesComment-is-changes

If you accept, the changes become part of the document; If you reject the modification done is removed and that portion 
becomes Orginal before modification.

Protect, Compare and MergeProtect, Compare and Merge    

You can also password protect the
track changes document. Simply
click on the protect icon from the
toolbar or select from the menu. In
the next window enter a password
to protect.

You can also compare or merge the
current document with another
document. It would give you a nice
merge and comparison view of
delete and insert highlighted.

https://libreofficehelp.com/wp-content/uploads/2020/07/Comment-is-changes.png


HyperlinksHyperlinks    
Alternatively referred to as a link, a hyperlink is a text or graphic in a document that links to a resource such as webpage 
address or a file.

To create a hyperlink in LibreOffice Writer, follow these steps:

1. Select the text that you want to turn into a hyperlink.

2. Click on the "Insert" menu, and then select "Hyperlink" or use the keyboard shortcut Ctrl+K.

3. In the "Hyperlink" Dialogue box that appears, enter the URL or file path of the destination you want to link to.

4. If you want the link to open in a new window, select the "Target" tab and choose "New window" under "Frame".

5. Click "Apply" to create the hyperlink.

6. To test the link, click on it in your document while holding down the Ctrl key, or by right-clicking and selecting "Open 
Hyperlink" from the context menu.

  Footnotes and Endnotes

Footnotes and Endnotes are basically references to additional information found on the bottom of the document. Footnotes 
appear at the bottom of the page on which they are referenced. Endnotes are collected at the end of a document. 

Footnoted vs EndnotesFootnoted vs Endnotes    

If you have a very long piece of text to enter, it might be more appropriate to add this as an endnote. Similarly with references, 
where the reader is more likely to need this information after they have read your paper, these should be added as endnotes.



Inserting footnotes or endnotesInserting footnotes or endnotes    

To insert a footnote or endnote:

1.Click right next to the text you want to reference.

2.Click the footnote   or endnote   button from the Standard toolbar.

3.The cursor will be moved to the footnote or endnote area, prompting you to type the text.

Now the reference will appear on your text with an number. You can also use the number as a link to the footnote or endnote.

Delete footnotes and endnotes

To delete simply delete the reference number inside your document , not the actual footnote or endnote area.



Drawing ObjectsDrawing Objects    
Writer uses the Draw component to insert and edit lines, shapes, text boxes and other drawing objects. Later in this course we 
will cover the Draw component as a separate application. In this section we will cover the basics of drawing shapes in Writer. 

Text BoxesText Boxes    

Text boxes give you control over the position of a block of text in your document. You can place text boxes anywhere in the 
document and format them with background and borders.

Use text boxes to insert text anywhere in your document without being restricted from your page layout. Text boxes are also 
useful when you create posters, brochures and other similar publications



Insert Text BoxInsert Text Box    

Click the text box   icon on the Standard toolbar to insert a text box. Click and drag your mouse where you want to position 
the text box. It appears with a border that you can use to resize or reposition the text box. Type the text.

Lines, Shapes and other drawing objects  
Using the Draw component you can create any type of drawing to a Writer document.

Insert a line or a shapeInsert a line or a shape    

To insert a line or a shape click the line or shape   buttons on the Standard toolbar. Then drag with your mouse to draw
the line or shape.



More shapesMore shapes    

If you want more shapes to select from click on the Show Draw Functions   icon on the Standard toolbar. This displays 
the Drawing toolbar on the bottom Writer window which includes additional shapes such as symbols, arrows, stars and call out 
boxes.

Formatting Drawing ObjectsFormatting Drawing Objects    

Draw objects have common editing and formatting properties with the graphics objects. We can move, change size, wrap text 
and anchor. In addition every shape object has a border and an inner area.

When selecting a drawing object, the Toolbox with the shape properties is displayed, where you can configure the line and area 
properties. You can set line color, style and width and of course background color. More about drawing we will see when we get
to the LibreOffice Draw component lesson.



Deleting drawing objectsDeleting drawing objects    

To delete a drawing object just select it and press the backspace button

Language toolsLanguage tools    
In order to use this feature, the appropriate dictionaries for your language must be installed. By default, four dictionaries are 
installed: a spelling checker, a grammar checker, a hyphenation dictionary, and a thesaurus. 

Spelling and grammarSpelling and grammar    
Writer provides a spelling checker, which checks to see if each word in the document is in the installed dictionary. Also 
provided is a grammar checker, which can be used separately or in combination with the spelling checker.

Automatic Spell CheckingAutomatic Spell Checking    
Automatic Spell Checking checks each word as it is typed and displays a wavy red line under any unrecognized words.

Right-click on an unrecognized word to open a context menu. You can click on one of the suggested words to replace the 
underlined word with the one selected. When the word is corrected, the line disappears.



If Automatic Spell Checking is not enabled click Tools > Automatic Spell Checking menu command to enable it.

A word marked as unrecognized is not necessarily misspelled. It can simply be a name, acronym, a technical term or any other 
word that is not on the dictionary.

Spell checking an entire documentSpell checking an entire document    
To perform a combined spelling and grammar check on the document (or a text selection), click the Spelling and Grammar 

button   on the Standard toolbar, or choose Tools > Spelling and Grammar. This checks the document or selection and opens 
the Spelling and Grammar Dialogue if any unrecognized words are found. In order to use this, the appropriate dictionaries must 
be installed.



If an unrecognized word is found it is highlighted in red on the top pane. The bottom pane contains suggested replacement 
words for the highlighted word. The option to restart from the beginning of the document is offered on reaching the end of the 
document.

The elements of the Spelling and Grammar Dialogue are as follows.

Not in dictionaryNot in dictionary

The sentence containing the error is displayed in the pane. If an unrecognized word is found it is highlighted. The sentence or 
the word can be edited in the pane.



SuggestionsSuggestions

The pane contains suggested replacement words for the highlighted word. Select a word and then select Change or Change All 
to replace it.

Text languageText language

The language to be used for the spell and grammar checking can be selected from this list. If the spell check is enabled for this 
language, a check mark is displayed in front of it

IgnoreIgnore

This one instance of the underlined word will be ignored while the document is open. Other instances, if they exist, will still be 
underlined. This setting is not stored with the document.

Ignore AllIgnore All

All instances of the word in the document will be ignored, and the word will be added to the IgnoreAllList user-defined 
dictionary.

Add to DictionaryAdd to Dictionary

The word is added by default to the Standard dictionary.

ChangeChange

Replaces the unknown word with the suggested word. If the sentence was edited, the whole sentence is changed. For grammar, 
the suggested replacement is used to correct the text.



Change AllChange All

This replaces all instances of the word with the selected replacement word.

AutoCorrectAutoCorrect

This behaves in a similar fashion to AutoCorrect described above. However, the word is not replaced and you must select one of
the Change buttons.

Working with stylesWorking with styles    

Paragraph styles

When drafting a document, the most used style category is the paragraph styles. Here are some of the basic paragraph styles:



Table of ContentsTable of Contents    
Writer’s table of contents feature lets you build an automated table of contents from the headings in your document. These 
entries are automatically generated as hyperlinks in the table. Whenever changes are made to the text of a heading in the body of
the document or the page on which the heading appears, those changes automatically appear in the table of contents when it is 
next updated. 

Creating a table of contentsCreating a table of contents    

A table of contents or (TOC) is created from the headings of your document. Before you insert the TOC, make sure that you 
have applied headings and styled them consistently. For example, you can use the Heading 1 style for chapter titles and the 
Heading 2 and Heading 3 styles for chapter subheadings.



To insert a TOC:To insert a TOC:    

1.Place the cursor in the position where you want it to appear.

2.Select the menu command:
Insert > Table of Contents and Index > Table of Contents

Next the Insert Index or Table of Contents Dialogue will appear. On the left side of this window you can see a preview of the 
TOC. Press OK to insert the TOC and continue.



The TOC is automatically created and appears with a gray background color around the text. This color is there to remind you 
that the text is generated automatically and does not appear in print.

Editing the TOCEditing the TOC    

Most of the time you will probably find the default table of contents (TOC) to be what you need. If you want to change the look 
and other settings of the TOC you need to edit it.

To edit a TOC:

1.Right-click anywhere inside the TOC.

2.Select the Edit Table of Contents command from the context menu.



In the Index or Table of Contents tab you can change for example the title of the table of contents.

Update and deleteUpdate and delete    

Whenever you make changes to the text within the headings or add or delete one, these changes do not automatically appear in 
the TOC. To apply the changes and update the TOC, select the Update Table of Contents command from the context menu. 
Similarly, delete the TOC with the Delete Table of Contents command.



MACROSMACROS
In LibreOffice Writer, macros are small programs that automate repetitive tasks, perform calculations or generate reports. Here 
are the steps to create and use macros in LibreOffice Writer:

1. Click on "Tools" in the menu bar, then select "Macros" and then "Organize Macros" and "LibreOffice Basic".

2. In the "LibreOffice Basic Macros" Dialogue box, click on the "+" sign next to "My Macros" to expand it, and then select 
"Standard".

3. Click on the "New" button to create a new macro.

4. In the "Macro Organizer" Dialogue box, enter a name for your macro in the "Macro name" field.

5. Click on the "Edit" button to open the LibreOffice Basic editor, where you can write your macro code.

6. Write your macro code in the editor, using the LibreOffice Basic programming language.

7. Save your macro by clicking on the "Save" button in the LibreOffice Basic editor, and then close the editor.

8. To run your macro, click on "Tools" in the menu bar, then select "Macros" and then "Run Macro".

9. In the "Run Macro" Dialogue box, select the macro you want to run, and then click on the "Run" button.
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