
1. Editors
2.0 Introduction of 
Editors 
The term editor is means text editor, which 
is a software program that allows text by 
adding, deleting and rearranging letters, 
words, sentences and paragraphs.

Some examples of text editors:

Notepad - Windows text editor. 

WordPad - Windows text editor. 

Text Edit - Apple computer text editor. 

Emacs - Text editor for all platforms that is a
very powerful text editor. 



Vi and Vim - Mostly used with Linux but also
available with multiple platforms. 

Writer- Text editor and word processor

Notepad++- Notepad++ is a powerful 
alternative to Windows Notepad 

2.1 Notepad 
Notepad is a simple text editor included 
with version of Microsoft Windows and 
LibreOffice writer that allows you to create, 
open, and read plaintext files. Notepad is a 
common text-only (plain text) editor. The 
resulting files typically saved with the .txt

extension. It is a very elementary utility, but
gets the job done most of the time.



Notepad++ is a free source code editor and 
supports several languages. Running in the 
MS Windows environment, its use is 
governed by GPL License. It features syntax 
highlighting, code folding and limited auto 
completion for programming, scripting and 
markup languages. It may properly highlight
code written in a supported schema. 
Notepad++ is written in C++ and uses pure 
Win32 API and STL which ensures a higher 
execution speed and smaller program size.

2.1.1 Advantages of Using Notepad:

Save files as HTML files: Using Notepad you
can create your webpage using HTML, 
Write basic HTML tags, headers and save 
the file with htmi extension.



1. Notepad can be used as Windows 
Explorer Skipper for specific files that 
cannot be deleted. You can use Notepad to 
delete such files

2. Notepad can break the text to create 
some impressive text-based design.

3. Notepad is simple text editor that can 
also be used to write complex script. You 
can create scripts which results in 
formatting of hard drive as well as useful 
script like PC shutdown These scripts will be
executed with a simple click.

4. You can use Notepad as your digital diary,
Diary that will keep you up-to-date 
regarding whatever you write. Every time 
you type in notepad, you can automatically 
insert date and time.



5. Save text files using different encodings: 
You can also use Save As to change the 
encoding of your file to match a particular 
character set. 

6. Print text files: If there is nothing that 
you want to customize in the document 
that is going to be printed, open the File 
menu and click or tap Print. If you do want 
to customize the print. first click or tap on 
Page Setup, in the File menu.

7. Change the font of the text: It offers you 
a list of all your installed fonts, and the 
option to use bold, italic, and the like. 
However, unlike the way it works in 
programs like Microsoft Word, a change of 
font immediately affects the entire 
document. You cannot use one font in one 



part of the document and another font in 
another part of it.

Notepad has been around for a very long 
time and continues to be a useful desktop 
app for writing simple text and HTML. If you
need more than just the basics, we highly 
recommend Notepad++, which is an 
excellent free and open source option. 
Notepad++ supports syntax highlighting, 
regular expressions, auto-complete, and 
much more.

2.2 Downloading free 
Editors: Notepad++
Notepad++ is a free source code editor and 
Notepad replacement that supports several 



languages. Running in the MS Windows 
environment, its use is governed by GPL 
License. It features syntax highlighting, code
folding and limited auto completion for 
programming, scripting and markup 
languages. It may properly highlight code 
written in a supported schema. Notepad++ 
is written in C++ and uses pure Win32 API 
and STL which ensures a higher execution 
speed and smaller program size. By 
optimizing as many routines as possible 
without losing user friendliness, Notepad++ 
is trying to reduce the world carbon dioxide 
emissions. When using less CPU power, the 
PC can throttle down and reduce power 
consumption, resulting in a greener 
environment,



2.2.1 Procedure of download Notepad++ 
editor: 

Step 1: In your browser type official website
address: https://notepad-plus-plus.org.

Step 2: Select the latest Notepad++ version 
in left side frame and click on download 
Image. 

Step 3: Open the folder with the 
downloaded package on your computer. 
Click twice the .exe file t run the Installer 
and Follow all installation steps. 

Step 4: Select installation language

Step 5: Click on-Agree to the terms of the 
License Agreement

Step 6: Please wait when the system finish 
installation. That's all! Now you are ready to
us Notepad++ software for editing codes



2.2.2 Features of Notepad++

Syntax Highlighting and Syntax Folding. 

User Defined Syntax Highlighting and 
Folding: screenshot 1, screenshot 2, 
screenshot 3 and screenshot 

PCRE (Peri Compatible Regular Expression) 
Search / Replace. 

GUI entirely customizable: minimalist, tab 
with close button, multi-line tab, vertical 
tab and vertical document list 

Document Map

Auto-completion: Word completion, 
Function completion and Function 
parameters hint.. 

Multi-Document (Tab interface).

Multi-View, 



WYSIWYG (Printing). 

Zoom in and zoom out. 

Multi-Language environment supported. 

Bookmark

Macro recording and playback. 

Launch with different arguments. 

2.3 Sublime Text Editor 
Sublime Text is a proprietary cross-platform 
source code editor with a Python 
application programming interface (API). It 
natively supports many programming 
languages and markup languages, and 
functions can be added by users with plug-
ins, typically community-built and 
maintained under free-software licenses.



2.3.1 Procedure of downloading Sublime 
Text editor 

Step 1: You can download sublime text 
editor from its official website. Goto your 
browser type official website address Le: 
https://www.sublimetext.com

Step 2: After going to its official website 
follow the link given to download sublime 
text editor according to your OS (operating 
system) needs.

Step 3: Open the folder with the 
downloaded package on your computer. 
Click twice the .exe file (executable file) to 
run the Installer and Follow all installation 
steps. When you run the executable file, 
you can observe the following window on 
your screen and Click Next.



Step 4: Now, choose the destination 
location to install Sublime Text3 and click 
Next.

After clicking next button verify the 
destination folder and then click on Install 
button.

Step 5: Click on Finish botton to complete 
the installation.

Please wait when the system finish 
installation. That's all! Now you are ready to
use Sublime text editor software for editing 
codes. After the successful installation, your
editor will appear as shown below:

2.3.2 Features of Sublime Text Editor

1. Column selection and multi-select 
editing: This feature allows users to select 



entire columns a once or place more than 
one cursor in text, which allows for 
simultaneous editing. All cursors then 
behave as if each of them was the only one 
in the text. Commands like move by 
character move by line, text selection, move
by words, move by sub words, move to 
beginning/end of line. etc. affect all cursors 
independentiy.

2. Auto completion: Sublime Text will offer 
to complete entries as the user is typing 
depending on the language being used. It 
also auto-completes variables created by 
the user.

3. Syntax highlight and high contrast 
display: The dark background on Sublime 
Text is inten reduce eyestrain and increase 
the amount of contrast with the text.



4. In-editor code building: This feature 
allows users to run code for certain 
languages from within the editor, which 
eliminates the need to switch out to the 
command line and back again. This function
can also be set to build the code 
automatically every time the file is saved.

5. Snippets: This feature allows users to 
save blocks of frequently used code and 
assign keywords to them. The user can then
type the keyword and press tab to paste the
block of code whenever they require it.

6. Goto anything: This feature is a tool that 
allows users to switch between open, 
recent or project files and also navigate to 
symbols within them.



7. Other features: Sublime Text has a 
number of features in addition to these 
including....

a. Auto-save, which attempts to prevent 
users from losing their work. 

b. Customizable key assignments, a 
navigational tool which allows users to 
assign hotkeys to their choice of options in 
both the menus and the toolbar. 

c. Find as you type, begins to look for the 
text being entered as the user types 
without requiring a separate dialog box.

d. Spell check function corrects as you type

e. Macros facility.

f. Repeat the last action.



g. A wide selection of editing commands, 
including indenting and unindenting, 
paragraph reformatting and line joining.

2.4 Making use of 
Editors 
In above topic we have already discussed 
about features of Text editor. Text editors 
are used by a huge variety of people, for a 
huge variety of purposes. For example 
software programmers and web developers 
use text editors to write and edit in 
programming and markup languages. This is
one of the primary purposes of text editors, 
and many of the features of text editing 
software are built to help these users read 



and write code. However, text editors are 
ideal tools for anyone who needs to write 
quickly and simply, read source code, or 
create text files.

With more advanced text editors come 
more advanced and useful features. Syntax 
highlighting, one of the most useful tools in 
a text editor's collection, color codes text 
based on the programming/markup 
language it written in.

2.5 File creation and 
editing 



Here we see file creation and editing by 
using notepad++ application and also by 
using sublime editor. 

1. File creation and editing by using 
Notepad++ editor: A text editor is a type of 
computer program that edits plain text. 
Such programs are sometimes known as 
"notepad" software, following the naming 
of Microsoft Notepad. A notepad is a simple
text editor tool that comes with windows by
default. It is one tool that is used by every 
individual to write or edit text files. It 
support almost all the languages and it 
saves the file with .txt extension.

But here we are using Notepad++ editor 
which is a free source code editor and is a 
replacement of the notepad. It additionally 



supports more languages. It offers plug-in 
support, syntax highlighting and a general 
overall experience upgrade.

Here we see how to create a simple, text-
based webpage by using your Windows 
computer Notepad++ application. You'll use
HTML as your webpage's language.

Step by step file creation process

Step 1: Open Notepad++ editor.

Step 2: Set in which language you are going 
to write you're coding. Now our purpose is 
to write a HTML program. Then select 
Language menu bar>H>HTML.

Step 3: Write below code. fra fagy a ford |

<HTML>



<BODY>

HELLO WORLD !!!

</BODY>

</HTML>

File creation is over.

Step 4: Then Save this file by using.html 
extension.

File editing process

Step 5: Here we want to add some more 
lines, so that we need to edit the file. Then 
put cursor where you want to add. Here we 
want to add two more line like...

It looks like above figure. So our editing is 
over. Now it is time to save the file as web 
page.



2. File creation and editing by using 
Sublime text editor: Sublime Text is 
another popular text editor. It is proprietary
software, not open source. Here we see 
how to create a simple, text-based webpage
by using sublime text editor.

Step by step file creation and editing 
process:

Step 1: Open Sublime Text editor.

Step2: Set in which language you are going 
to write the code. Since our purpose is to 
write the HTML program. So we need to go 
to the View > Syntax> HTML.

Step3: After clicking HTML, goto your page 
and type the <HTML> tag. Then, the syntax 
of HTML code is automatically comes up. 



Now you are able to write the HTML code 
here.

Step4: After writing the code, Save the 
above file with .html extension. Now your 
file is ready.

Step 5: Open the file you want to edit. For 
opening the file goto the File Menu > Open 
File / Open Folder or press Ctrl+0.

Step6: Select the file you want to open and 
click on the Open button. Now your file is 
open and you can edit/update it.

1.6 Saving
In above topic we already created a html 
file, now the question is how to save our 
required file in web page format.



For saving the file in notepad++ follow the 
steps given below: 

Step 1: Click on File menu> Save As, Save as 
dialogue box will appear like below figures 

Step 2: Provide a name of the file in File 
Name box, ex: First Program

Step 3: Next we need to save our file in the 
format of HTML, so that Choose save as 
type, for this select in list drop down box 
and choose "Hyper text markup language 
file"

Step 4: Select your destination folder where
you want to save your web page

Step 5: Click on Save Button. Your file is 
saved in form of HTML. 



For saving the file in Sublime Text editor 
follow the steps given below: 

Step 1: Click on File menu> Save As. Now 
the Save As dialogue box will appear like 
below figure. 

Step 2: Provide a name of the file in File 
Name box, ex: First Program

Step 3: Next we need to save our file in the 
format of HTML, so that Choose Save as 
type, for this select in list drop down box 
and choose "Hyper text markup language 
file".

Step 4: Select your destination folder where
you want to save your web page. 

Step 5: Click on Save Button. Your file is 
saved in form of HTML.




